API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProfileConversionConvertFromCurrentUnits Method

Converts a profile string from current units to internal units (set in Units and decimals options).

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static bool ConvertFromCurrentUnits(
	string Profile,
	ref string ConvertedProfile
)

Parameters

Profile
Type: SystemString
The profile string to convert.
ConvertedProfile
Type: SystemString
The converted profile string.

Return Value

Type: Boolean
True if successfully converted the string.
See Also