API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MainWindowRemoveExternalWindow Method

Removes a registration done with AddExternalWindow(String, IntPtr).

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void RemoveExternalWindow(
	string Name,
	IntPtr Handle
)

Parameters

Name
Type: SystemString
The unique name of the form.
Handle
Type: SystemIntPtr
The handle to the form that is to be removed.
See Also