API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MainWindowAddExternalWindow Method

Registers the entire dialog to be insensitive at certain points, for example while modal Tekla Structures system dialog boxes are open. When insensitive, the dialog does not respond to any input. You can remove the registration of the dialog with RemoveExternalWindow(String, IntPtr).

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void AddExternalWindow(
	string Name,
	IntPtr Handle
)

Parameters

Name
Type: SystemString
The unique name of the form.
Handle
Type: SystemIntPtr
The handle to the form that is to be added.
See Also