API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LocalizationRegisterLocalizationCallback Method

Registers a localization callback which is used to translate the registered control types.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void RegisterLocalizationCallback(
	LocalizationLocalizationCallback cb,
	params Type[] types
)

Parameters

cb
Type: Tekla.Structures.DialogLocalizationLocalizationCallback
The localization delegate.
types
Type: SystemType
An array of types which will trigger the current delegate.
See Also