API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LocalizationLoadFile Method

Loads the localization strings from a file. Several files may be used concurrently, just call LoadFile for each file. The translations are searched in the loading order and the first match is returned. The method uses the extension of the filename to identify the file type (".xml", ".aid" or ".ail").

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void LoadFile(
	string fileName
)

Parameters

fileName
Type: SystemString
The file to be loaded.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.