API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LocalizationLoadAilFile Method

Loads the localization strings from an ail file. Several files may be used concurrently, just call LoadAilFile for each file. The translations are searched in the loading order and the first match is returned.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void LoadAilFile(
	string fileName
)

Parameters

fileName
Type: SystemString
The ail file to be loaded.
See Also