API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

HelpViewerDisplayHelpTopicIndependent Method

Method for opening Tekla Structures help viewer independently from given file path with given help topic and language.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static bool DisplayHelpTopicIndependent(
	string helpViewerFilePath,
	string helpTopic,
	string language
)

Parameters

helpViewerFilePath
Type: SystemString
Full file path to HelpViewer.exe containing the name of the executable.
helpTopic
Type: SystemString
Help topic (e.g. Help file name without extension).
language
Type: SystemString
Help language. Defaults to enu.

Return Value

Type: Boolean
True if success, otherwise false.
See Also