![]() | FormBase Methods |
The FormBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | ApplyValues |
Loads the dialog values from a file and performs Apply on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
|
![]() | GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
|
![]() ![]() | GetUnitDecimals |
Gets the number of decimals Tekla Structures uses with the specified unit type.
|
![]() ![]() | InitializeAngleUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying the angle unit and
initializes Angle class to use that.
|
![]() ![]() | InitializeDistanceUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying the "length" unit and
initializes the distance datatype to use that.
|
![]() | InitializeForm |
Prepares the data storage for the dialog and scans through the fields.
|
![]() ![]() | InitializeUnitDecimals |
Gets the number of decimals Tekla Structures uses for displaying its units and
initializes the Tekla.Structures.Datatype classes to use them.
|
![]() | LoadValues |
Loads the dialog values from a file. To match the files to a certain dialog,
the file suffix is set as the dialog type's name.
|
![]() | ModifyValues |
Loads the dialog values from a file and performs Modify on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
|
![]() | SaveValues |
Serializes the dialog values to an xml file.
|
![]() ![]() | SetAttributeValue |
Sets a value for the given control. When the dialog is not shown, setting a property
directly for a control (such as textBox1.Text = "text") will not work for controls that
have a Tekla Structures AttributeTypeName set. This method is going to have to be used
to set the value.
|
![]() | ShowForm |
Displays the form.
|
![]() | UpdateValues | Obsolete.
Rereads and updates all the field values on the form.
|