API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ErrorDialogShow Method (String, String, ErrorDialogSeverity)

Shows a new error dialog.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static void Show(
	string Message,
	string Details,
	ErrorDialogSeverity Severity
)

Parameters

Message
Type: SystemString
The message to display in the dialog.
Details
Type: SystemString
The details to display in the dialog.
Severity
Type: Tekla.Structures.DialogErrorDialogSeverity
The severity of the message.
See Also