API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ErrorDialogShow Method (Exception, ErrorDialogSeverity)

Shows a new error dialog.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static void Show(
	Exception Ex,
	ErrorDialogSeverity Severity
)

Parameters

Ex
Type: SystemException
The exception to display in the dialog.
Severity
Type: Tekla.Structures.DialogErrorDialogSeverity
The severity of the exception.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the Ex parameter is null.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.