API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DialogsLoadAttributeFileNameToDialogAndModify Method (String)

Uses the attributes found from the attribute file as the current values for the specified dialog. Modifies the current selected instance. Applied values for this dialog are not changed.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static int LoadAttributeFileNameToDialogAndModify(
	string param
)

Parameters

param
Type: SystemString
Not used.

Return Value

Type: Int32
0 always. The return value is not useful because it is not sent to the Tekla Structures core.
See Also