API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AttributeTypeNameEditorGetEditStyle Method

Gets the editor style used by the EditValue method.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public override UITypeEditorEditStyle GetEditStyle(
	ITypeDescriptorContext context
)

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of the editor used by the EditValue method. If the UITypeEditor does not support the method, then GetEditStyle will return None.
See Also