API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AttributeTypeNameEditor Class

The AttributeTypeNameEditor class provides a user interface for selecting a type for the bound attribute.
Inheritance Hierarchy
SystemObject
  System.Drawing.DesignUITypeEditor
    Tekla.Structures.DialogAttributeTypeNameEditor

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class AttributeTypeNameEditor : UITypeEditor

The AttributeTypeNameEditor type exposes the following members.

Constructors
  NameDescription
Public methodAttributeTypeNameEditor
Initializes a new instance of the AttributeTypeNameEditor class
Top
Methods
  NameDescription
Public methodEditValue
Edits the specified object's value using the editor style indicated by the GetEditStyle method.
(Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public methodGetEditStyle
Gets the editor style used by the EditValue method.
(Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also