API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StringConverter Class

The StringConverter class converts types to and from the string datatype.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public class StringConverter : TypeConverter

The StringConverter type exposes the following members.

Constructors
  NameDescription
Public methodStringConverter
Initializes a new instance of the StringConverter class
Top
Methods
  NameDescription
Public methodCanConvertFrom
Checks whether the conversion can be made from the source type to the string datatype.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public methodCanConvertTo
Checks whether the conversion can be made from the string datatype to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public methodConvertFrom
Converts an object from the given culture to the Tekla.Structures.Datatype.String type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public methodConvertTo
Converts an object from the string datatype to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also