API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StringInequality Operator

Compares a string value with a Datatype.String value.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static bool operator !=(
	string Left,
	String Right
)

Parameters

Left
Type: SystemString
The string value to be compared.
Right
Type: Tekla.Structures.DatatypeString
The Datatype.String value to be compared.

Return Value

Type: Boolean
True if the values are different.
See Also