API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SettingsProxy Class

The SettingsProxy class is a proxy for the settings.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Tekla.Structures.DatatypeSettingsProxy

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public class SettingsProxy : MarshalByRefObject

The SettingsProxy type exposes the following members.

Constructors
  NameDescription
Public methodSettingsProxy
Creates a new settings proxy instance.
Top
Methods
  NameDescription
Public methodGetValue
Gets the value of the setting with the given name.
Public methodSetValue
Sets a setting to a value.
Public methodTryGetValue
Tries to get the value of the setting with the given name.
Top
See Also