API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SettingsGetValue Method

Gets the value of the setting with the given name.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static Object GetValue(
	string name
)

Parameters

name
Type: SystemString
The name of the setting.

Return Value

Type: Object
The value of the given setting.
See Also