API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IntegerConverterConvertTo Method

Converts an object from the the integer datatype to the given destination type.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public override Object ConvertTo(
	ITypeDescriptorContext context,
	CultureInfo culture,
	Object value,
	Type destinationType
)

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The context.
culture
Type: System.GlobalizationCultureInfo
The target culture.
value
Type: SystemObject
The integer datatype object to be converted.
destinationType
Type: SystemType
The destination type.

Return Value

Type: Object
The given integer datatype object converted to the new type.
See Also