API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IntegerEquality Operator

Compares an int value with a Datatype.Integer value.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static bool operator ==(
	int Left,
	Integer Right
)

Parameters

Left
Type: SystemInt32
The int value to be compared.
Right
Type: Tekla.Structures.DatatypeInteger
The Datatype.Integer value to be compared.

Return Value

Type: Boolean
True if the values are the same.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.