API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DoubleConverter Class

The DoubleConverter class converts types to and from the double datatype.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public class DoubleConverter : TypeConverter

The DoubleConverter type exposes the following members.

Constructors
  NameDescription
Public methodDoubleConverter
Initializes a new instance of the DoubleConverter class
Top
Methods
  NameDescription
Public methodCanConvertFrom
Checks whether the conversion can be made from the source type to the double datatype.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public methodCanConvertTo
Checks whether the conversion can be made from the double datatype to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public methodConvertFrom
Converts an object from the given culture to the Tekla.Structures.Datatype.Double type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public methodConvertTo
Converts an object from the double datatype to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also