API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceListRemove Method

Removes the specified item.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
Examples
This example shows how to remove a Distance instance from a DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance[] distances = { new Distance(30.2), new Distance(40, Distance.UnitType.Inch) };
           DistanceList distanceList = new DistanceList(distances);

           // Distances can be removed by value. The first matching distance will be removed.
           bool removed = distanceList.Remove(new Distance(40, Distance.UnitType.Inch));
       }
}
See Also