API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceListInsert Method

Inserts an item at the specified position.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
Examples
This example shows how to insert a new Distance instance at the beginning of the DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance[] distances = { new Distance(30.2), new Distance(2.3) };
           DistanceList distanceList = new DistanceList(distances);

           distanceList.Insert(0, new Distance(2));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.