API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceListIsReadOnly Property

Gets a boolean value indicating whether the collection is read-only.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public bool IsReadOnly { get; }

Property Value

Type: Boolean
A boolean value indicating whether the collection is read-only.

Implements

ICollectionTIsReadOnly
Remarks
DistanceLists are always mutable.
See Also