![]() | DistanceList Structure |
A list of Distance instances.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1

The DistanceList type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | DistanceList |
Initializes a new instance of the structure.
|

Name | Description | |
---|---|---|
![]() ![]() | Count |
Gets the number of items in the list.
|
![]() | IsReadOnly |
Gets a boolean value indicating whether the collection is read-only.
|
![]() ![]() | Item |
Gets or sets the item at the specified index.
|

Name | Description | |
---|---|---|
![]() ![]() | Add |
Adds the specified item at the end of the list.
|
![]() ![]() | Clear |
Clears the list.
|
![]() ![]() | Contains |
Determines whether the specified item is in the list.
|
![]() ![]() | CopyTo |
Copies the contents of the list to an array.
|
![]() ![]() | GetEnumerator |
Gets an enumerator for enumeraring through the list.
|
![]() ![]() | IndexOf |
Returns the index of the first matching item in the list.
|
![]() ![]() | Insert |
Inserts an item at the specified position.
|
![]() ![]() ![]() | Parse(String) |
Parses a distance list from a string representation.
|
![]() ![]() ![]() | Parse(String, IFormatProvider) |
Parses a distance list from a string representation.
|
![]() ![]() ![]() | Parse(String, IFormatProvider, DistanceUnitType) |
Parses a distance list from a string representation.
|
![]() ![]() | Remove |
Removes the specified item.
|
![]() ![]() | RemoveAt |
Removes an item at the specified position.
|
![]() ![]() | ToArray |
Copies the contents of the list into a new array.
|
![]() ![]() | ToString |
Returns the string representation of the distance list.
(Overrides ValueTypeToString.) |
![]() ![]() | ToString(IFormatProvider) |
Returns the string representation of the distance list.
|
![]() ![]() | ToString(String, IFormatProvider) |
Returns the string representation of the distance list.
|
![]() ![]() | ToString(String, IFormatProvider, DistanceUnitType) |
Returns the string representation of the distance list.
|

DistanceLists are used to store related Distance instances
in an enumerable, formattable list.