![]() | DistanceConverter Class |
The DistanceConverter class converts types to and from the distance type.

Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1

The DistanceConverter type exposes the following members.

Name | Description | |
---|---|---|
![]() | DistanceConverter | Initializes a new instance of the DistanceConverter class |

Name | Description | |
---|---|---|
![]() | CanConvertFrom |
Checks whether the conversion can be made from the source type to the distance type.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).) |
![]() | CanConvertTo |
Checks whether the conversion can be made from the distance type to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).) |
![]() | ConvertFrom |
Converts an object from the given culture to the distance type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).) |
![]() | ConvertTo |
Converts an object from the distance type to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).) |