API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceToString Method (String)

Creates a string representation of the distance.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public string ToString(
	string format
)

Parameters

format
Type: SystemString
The format string.

Return Value

Type: String
The string representation of the distance.
Examples
This example shows how to specify a number format when converting a Distance instance to a string.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);

           // We can use the number format string to specify the precision. In this case, we use two decimal places.
           string formattedString = distance.ToString("0.00");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.