API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceToFractionalFeetAndInchesString Method (IFormatProvider)

Creates a string representation of the distance in feet and inches.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public string ToFractionalFeetAndInchesString(
	IFormatProvider formatProvider
)

Parameters

formatProvider
Type: SystemIFormatProvider
The number format provider.

Return Value

Type: String
The string representation of the distance.
Examples
This example shows how to specify a format provider when converting a Distance instance into a fractional string representation of feet and inches.
using Tekla.Structures.Datatype;
using System.Globalization;

public class Example
{
       public void Example1()
       {
           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);

           string formattedString = distance.ToFractionalFeetAndInchesString(CultureInfo.InvariantCulture);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.