API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceConvertTo Method

Converts the distance to the specified units.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public double ConvertTo(
	DistanceUnitType unitType
)

Parameters

unitType
Type: Tekla.Structures.DatatypeDistanceUnitType
The distance unit type.

Return Value

Type: Double
The distance in the specified units.
Examples
This example shows how to convert a Distance instance into real world units.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);

           double distanceInInches = distance.ConvertTo(Distance.UnitType.Inch);
       }
}
See Also