API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceValue Property

Gets or sets the distance value in current units.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public double Value { get; set; }

Property Value

Type: Double
The distance value in current units.

Implements

IDoubleDataTypeValue
Examples
This example shows how to perform calculations with distances in different units.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // The default unit type is millimeter.
           Distance value1 = new Distance(30);

           // Other unit types must be specified explicitly.
           Distance value2 = new Distance(2, Distance.UnitType.Inch);

           // Perform sum calculation using the same units for both distances.
           Distance sumOfDistances = new Distance(value1.Value + value2.Value, Distance.CurrentUnitType);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.