![]() | BooleanConverter Class |
The BooleanConverter class converts types to and from the boolean type.

Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1

The BooleanConverter type exposes the following members.

Name | Description | |
---|---|---|
![]() | BooleanConverter | Initializes a new instance of the BooleanConverter class |

Name | Description | |
---|---|---|
![]() | CanConvertFrom |
Checks whether the conversion can be made from the source type to the boolean type.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).) |
![]() | CanConvertTo |
Checks whether the conversion can be made from the boolean type to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).) |
![]() | ConvertFrom |
Converts an object from the given culture to the boolean type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).) |
![]() | ConvertTo |
Converts an object from the boolean type to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).) |