API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Boolean Structure

The Boolean datatype.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
[TypeConverterAttribute(typeof(BooleanConverter))]
public struct Boolean : IXmlSerializable, IDataType

The Boolean type exposes the following members.

Constructors
  NameDescription
Public methodBoolean
Initializes a new instance of the structure.
Top
Properties
  NameDescription
Public propertyValue
Gets or sets the boolean value.
Top
Remarks
The purpose of this type is to enable dialog field binding with StructuresExtender. You don't need to use this type in your own programs.
See Also