![]() | Tekla.Structures.Datatype Namespace |
The Tekla.Structures.Datatype namespace contains methods related to different datatypes.

Class | Description | |
---|---|---|
![]() | Angle |
Provides support for angles using either the current Tekla Structures units, or user defined units
|
![]() | AngleList |
This class provides methods to handle lists of angles
|
![]() | BooleanConverter |
The BooleanConverter class converts types to and from the boolean type.
|
![]() | Constants |
The Constants class is a repository for constants used by the Tekla.Structures.Datatype.* types.
|
![]() | DistanceConverter |
The DistanceConverter class converts types to and from the distance type.
|
![]() | DistanceListConverter |
The DistanceListConverter class converts types to and from the distance list type.
|
![]() | DoubleConverter |
The DoubleConverter class converts types to and from the double datatype.
|
![]() | EnumConverter | Type converter for Enum |
![]() | IntegerConverter |
The IntegerConverter class converts types to and from the integer datatype.
|
![]() | Settings |
The Settings class contains the currently active unit settings.
|
![]() | SettingsProxy |
The SettingsProxy class is a proxy for the settings.
|
![]() | StringConverter |
The StringConverter class converts types to and from the string datatype.
|

Structure | Description | |
---|---|---|
![]() | Boolean |
The Boolean datatype.
|
![]() ![]() | Distance |
The Distance datatype.
|
![]() | DistanceList |
A list of Distance instances.
|
![]() | Double |
The Double datatype.
|
![]() | EnumE | The Enum datatype generic. |
![]() | Integer |
The Integer datatype.
|
![]() | String |
The String datatype.
|

Interface | Description | |
---|---|---|
![]() | IDataType |
The IDataType interface is the root interface for converting all the
Tekla.Structures.Datatype.* types to basic types supported by the
Tekla Structures Object Dialog tree.
|
![]() | IDoubleDataType |
The IDoubleDataType interface is an interface for the Tekla.Structures.Datatype.*
types whose value is a double.
|
![]() | IIntDataType |
The IIntDataType interface is an interface for the Tekla.Structures.Datatype.*
types whose value is an integer.
|
![]() | IStringDataType |
The IStringDataType interface is an interface for the Tekla.Structures.Datatype.*
types whose value is a string.
|

Enumeration | Description | |
---|---|---|
![]() | AngleUnitType |
The angle units.
|
![]() | DistanceUnitType |
The distance units.
|