API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyVisibilityEnum Enumeration

The visibility of the user property.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public enum UserPropertyVisibilityEnum
Members
  Member nameValueDescription
VISIBILITY_NORMAL0 The user property is visible and the user can modify it.
VISIBILITY_READONLY1 The user property is visible but the user cannot modify it.
VISIBILITY_HIDDEN2 The user property is hidden.
See Also