API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyOption Class

The UserPropertyOption class contains the properties of a user property value option.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsUserPropertyOption

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public sealed class UserPropertyOption

The UserPropertyOption type exposes the following members.

Constructors
  NameDescription
Public methodUserPropertyOption
Initializes a new instance of the UserPropertyOption class
Top
Properties
  NameDescription
Public propertyDoubleValue
The double value.
Public propertyIntValue
The integer value.
Public propertyOptionLabel
The option name.
Public propertyOptionLabelTranslated
The translated option name.
Public propertyStringValue
The string value.
Top
See Also