API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemSetOptions Method (ListKeyValuePairString, String)

Sets the value options of a string property. The maximum count of options is 400.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool SetOptions(
	List<KeyValuePair<string, string>> StringOptions
)

Parameters

StringOptions
Type: System.Collections.GenericListKeyValuePairString, String
The new value options.

Return Value

Type: Boolean
True on success.
See Also