API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemGetOptions Method (ListKeyValuePairInt32, String, Boolean)

Gets the value options of an integer property.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool GetOptions(
	ref List<KeyValuePair<int, string>> IntOptions,
	bool translatedLabels
)

Parameters

IntOptions
Type: System.Collections.GenericListKeyValuePairInt32, String
The value options.
translatedLabels
Type: SystemBoolean
if set to true labels translated to current language are returned, otherwise the resource key of label is returned.

Return Value

Type: Boolean
True on success.
See Also