API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemGetOptions Method (ListKeyValuePairInt32, String)

Gets the value options of an integer property. Option strings are translated when translation is available.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool GetOptions(
	ref List<KeyValuePair<int, string>> IntOptions
)

Parameters

IntOptions
Type: System.Collections.GenericListKeyValuePairInt32, String
The value options.

Return Value

Type: Boolean
True on success.
See Also