API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemGetOptions Method (ListKeyValuePairDouble, String)

Gets the value options of a double property. Option strings are translated when translation is available.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool GetOptions(
	ref List<KeyValuePair<double, string>> DoubleOptions
)

Parameters

DoubleOptions
Type: System.Collections.GenericListKeyValuePairDouble, String
The value options.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.