API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ShapeItemSelect Method (String)

Selects the shape based on the given name from the database.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool Select(
	string name
)

Parameters

name
Type: SystemString
The name of the shape.

Return Value

Type: Boolean
True on success. False if the shape was not found.
See Also