API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarItemEnumeratorSelectRebarItem Method (String, String, String)

Selects a rebar item in the rebar database with the given grade, size and usage.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public static RebarItem SelectRebarItem(
	string Grade,
	string Size,
	string Usage
)

Parameters

Grade
Type: SystemString
The grade of the rebar item to select.
Size
Type: SystemString
The size of the rebar item to select.
Usage
Type: SystemString
The usage of the rebar item to select.

Return Value

Type: RebarItem
The first RebarItem that matches the conditions.
See Also