RebarItemEnumerator Class

The RebarItemEnumerator class allows to loop through the catalog rebar items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsRebarItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarItemEnumerator : IEnumerator

The RebarItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a rebar item instance of the current element.
Top
Methods
  NameDescription
Public methodStatic memberDeleteRebarItem
Delete the RebarItem from the list
Public methodStatic memberGetRebarHeaderItems
Gets the header items from the rebar catalog header.
Public methodGetSize
Returns the total amout of items.
Public methodStatic memberInsertRebarItem
Insert the RebarItem in to the list
Public methodStatic memberModifyRebarItem
Modify the RebarItem in the list
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodStatic memberRebarItemExists
Check RebarItem is available in database file
Public methodReset
Resets the enumerator to the beginning.
Public methodStatic memberSelectRebarItem(String, String)
Selects a rebar item in the rebar database with the given grade and size.
Public methodStatic memberSelectRebarItem(String, Double, Boolean)
Selects a rebar item in the rebar database with the given grade and nominal diameter.
Public methodStatic memberSelectRebarItem(String, String, Double)
Selects a rebar item in the rebar database with the given grade, size and bending radius.
Public methodStatic memberSelectRebarItem(String, String, String)
Selects a rebar item in the rebar database with the given grade, size and usage.
Public methodStatic memberSelectRebarItem(String, Double, Double, Boolean)
Selects a rebar item in the rebar database with the given grade, nominal diameter and bending radius.
Public methodStatic memberSelectRebarItem(String, Double, String, Boolean)
Selects a rebar item in the rebar database with the given grade, nominal diameter and bending radius.
Public methodStatic memberSelectRebarItem(String, String, String, String)
Selects a rebar item in the rebar database with the given grade, size, usage and code.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next