API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarItemSelect Method (String, Double, Double, Boolean)

Selects the rebar item in the rebar database.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool Select(
	string Grade,
	double Diameter,
	double BendRadius,
	bool UseNominalDiameter
)

Parameters

Grade
Type: SystemString
The grade of the rebar item to select.
Diameter
Type: SystemDouble
The diameter of the rebar item to select.
BendRadius
Type: SystemDouble
The bending radius of the rebar item to select.
UseNominalDiameter
Type: SystemBoolean
If set to false, the item is selected based on the actual diameter. If true, the item is selected based on the nominal diameter.

Return Value

Type: Boolean
True on success.
See Also