![]() | ProfileItemParameter Class |
The ProfileItemParameter class contains the information of one profile parameter
(property name, symbol, unit and unit type). A profile item can contain a maximum
of 50 profile parameters.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The ProfileItemParameter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ProfileItemParameter | Initializes a new instance of the ProfileItemParameter class |

Name | Description | |
---|---|---|
![]() | CrossSectionNumber |
The number of the cross section the parameter belongs to.
|
![]() | ParameterUnitType |
Defines the parameter unit type.
|
![]() | Property |
The description of the profile item parameter. Corresponds to the 'Property' in the
Tekla Structures profile catalog dialog, and the 'Label in dialog box' in the variable
dialog in the Sketch Editor.
|
![]() | StringValue |
The string value of the profile item parameter.
|
![]() | Symbol |
The symbol of the profile item parameter.
|
![]() | Value |
The value of the profile item parameter.
|