API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProfileItemProfileItemTypeEnum Enumeration

Defines the different profile item types.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public enum ProfileItemTypeEnum
Members
  Member nameValueDescription
ALL_PROFILES-1 All profiles.
PROFILE_UNKNOWN0 The unknown profile.
PROFILE_I1 The I profile.
PROFILE_L2 The L profile.
PROFILE_Z3 The Z profile.
PROFILE_U4 The U profile.
PROFILE_PL5 The plate profile.
PROFILE_D6 The circular section profile.
PROFILE_PD7 The circular hollow section profile.
PROFILE_P8 The rectangular hollow section profile.
PROFILE_C9 The C profile.
PROFILE_T10 The T profile.
PROFILE_HK11 The welded box profile.
PROFILE_HQ13 The HQ profile
PROFILE_ZZ15 The ZZ profile.
PROFILE_CC16 The CC profile.
PROFILE_CW17 The CW profile.
PROFILE_CU18 The CU profile.
PROFILE_EB19 The EB profile.
PROFILE_BF20 The BF profile.
PROFILE_SPD21 The SPD profile.
PROFILE_EC22 The EC profile.
PROFILE_ED23 The ED profile.
PROFILE_EE24 The EE profile.
PROFILE_EF25 The EF profile.
PROFILE_EZ26 The EZ profile.
PROFILE_EW27 The EW profile.
PROFILE_POLYGON_PLATE51 The polygon plate profile.
PROFILE_FPL2 The FPL profile.
PROFILE_SP101 The SP profile.
PROFILE_RCDL102 The RCDL profile.
PROFILE_RCXX103 The RCXX profile.
PROFILE_RCL104 The RCL profile.
PROFILE_RCDX105 The RCDX profile.
PROFILE_RCX106 The RCX profile.
PROFILE_USER_DEFINED998 The user-defined, fixed profile.
PROFILE_USER_PARAMETRIC999 The user-defined, parametric profile.
See Also