![]() | ProfileItem Class |
The ProfileItem abstract class contains the common information of catalog
profiles (parametric and library).

SystemObject
Tekla.Structures.CatalogsProfileItem
Tekla.Structures.CatalogsLibraryProfileItem
Tekla.Structures.CatalogsParametricProfileItem
Tekla.Structures.CatalogsProfileItem
Tekla.Structures.CatalogsLibraryProfileItem
Tekla.Structures.CatalogsParametricProfileItem
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The ProfileItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | aProfileItemParameters |
An array list with the profile item parameters.
|
![]() | IsMultiCrossSectionUserParametric |
Whether the profile is a parametric user-defined multi cross section profile.
|
![]() | IsSketchedUserParametric |
Whether the profile is a parametric user-defined sketched profile.
|
![]() | NumberOfCrossSections |
The number of cross sections in the profile item.
|
![]() | ParameterString |
The profile item parameter string.
|
![]() | ProfileItemSubType |
The profile item subtype.
|
![]() | ProfileItemType |
The profile item type.
|

Name | Description | |
---|---|---|
![]() ![]() | Export |
Exports the profile item in the profile database to given file name.
Currently library profiles, sketch profiles and clb profiles are supported.
Library profiles are exported to *.lis format.
Sketch profiles are exported to *.uel format.
Clb profiles are exported to *.clb format.
If path is not given profile is exported to model folder.
If filename is empty profile name or prefix is used as filename.
|
![]() ![]() | GetCrossSection |
Returns list of cross section points of inner surfaces from the profile item.
|
![]() | GetHighAccuracyCrossSection |
Get cross section with high accuracy.
|
![]() | IsProfileUserDefined |
Whether the profile is a fixed user-defined profile.
|
![]() | IsProfileUserParametric |
Whether the profile is a parametric user-defined profile. If so,
the prefix can be asked by type and subtype.
|
![]() | ModifyProfileItemAnalysisParameter |
Modify analysis parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
|
![]() | ModifyProfileItemParameter |
Modify parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
|
![]() | ModifyProfileItemUserParameter |
Modify user parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
|
![]() | Select |
Selects the profile item in the profile database.
|