API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParametricProfileItemGetParametricProfilePrefix Method

Gets the parametric profile item prefix using the given subtype. This can be used after retrieving a library profile that has a parametric user-defined type.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public static string GetParametricProfilePrefix(
	int Subtype
)

Parameters

Subtype
Type: SystemInt32
The profile item subtype.

Return Value

Type: String
The parametric profile item prefix.
See Also