![]() | ParametricProfileItem Class |
The ParametricProfileItem class contains information from parametric profiles in
the catalog. Parametric profile items can be enumerated using a profile item enumerator.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The ParametricProfileItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | ParametricProfileItem |
Creates a new parametric profile item instance.
|

Name | Description | |
---|---|---|
![]() | aProfileItemParameters |
An array list with the profile item parameters.
(Inherited from ProfileItem.) |
![]() | IsMultiCrossSectionUserParametric |
Whether the profile is a parametric user-defined multi cross section profile.
(Inherited from ProfileItem.) |
![]() | IsSketchedUserParametric |
Whether the profile is a parametric user-defined sketched profile.
(Inherited from ProfileItem.) |
![]() | NumberOfCrossSections |
The number of cross sections in the profile item.
(Inherited from ProfileItem.) |
![]() | ParameterString |
The profile item parameter string.
(Inherited from ProfileItem.) |
![]() | ProfileItemSubType |
The profile item subtype.
(Inherited from ProfileItem.) |
![]() | ProfileItemType |
The profile item type.
(Inherited from ProfileItem.) |
![]() | ProfilePrefix |
The parametric profile item prefix.
|

Name | Description | |
---|---|---|
![]() | CreateProfileString |
Gets the parametric profile item prefix and adds parameter values.
|
![]() ![]() | Export |
Exports the profile item in the profile database to given file name.
Currently library profiles, sketch profiles and clb profiles are supported.
Library profiles are exported to *.lis format.
Sketch profiles are exported to *.uel format.
Clb profiles are exported to *.clb format.
If path is not given profile is exported to model folder.
If filename is empty profile name or prefix is used as filename.
(Inherited from ProfileItem.) |
![]() ![]() | GetCrossSection |
Returns list of cross section points of inner surfaces from the profile item.
(Inherited from ProfileItem.) |
![]() | GetHighAccuracyCrossSection |
Get cross section with high accuracy.
(Inherited from ProfileItem.) |
![]() ![]() | GetParametricProfilePrefix |
Gets the parametric profile item prefix using the given subtype. This can be used
after retrieving a library profile that has a parametric user-defined type.
|
![]() | IsProfileUserDefined |
Whether the profile is a fixed user-defined profile.
(Inherited from ProfileItem.) |
![]() | IsProfileUserParametric |
Whether the profile is a parametric user-defined profile. If so,
the prefix can be asked by type and subtype.
(Inherited from ProfileItem.) |
![]() | ModifyProfileItemAnalysisParameter |
Modify analysis parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | ModifyProfileItemParameter |
Modify parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | ModifyProfileItemUserParameter |
Modify user parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | Select |
Selects the profile item in the profile database.
(Inherited from ProfileItem.) |
![]() | Select(String) |
Selects the parametric profile item in the profile database using the given name.
|

It is possible to select a parametric profile item by its name:
using Tekla.Structures.Catalogs; public class Example { public void Example1() { ParametricProfileItem ParametricProfileItem = new ParametricProfileItem(); ParametricProfileItem.ProfilePrefix = "PHI"; ParametricProfileItem.Select(); } }