API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MaterialMarketSizesItemEnumeratorCurrent Property

Returns a MaterialMarketSizesItem instance with the current index.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public MaterialMarketSizesItem Current { get; }

Property Value

Type: MaterialMarketSizesItem
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when Current item cannot be accessed from the given location.
See Also