![]() | MaterialItemEnumerator Class |
The MaterialItemEnumerator class allows to loop through the catalog material items.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The MaterialItemEnumerator type exposes the following members.


Name | Description | |
---|---|---|
![]() | GetSize |
Returns the total amout of items.
|
![]() | MoveNext |
Moves to the next item in the enumerator.
|
![]() | Reset |
Resets the enumerator to the beginning.
|

The following example returns true if an item with the name S235JR has been found:
using Tekla.Structures.Catalogs; public class Example { public bool Example1() { bool Result = false; CatalogHandler CatalogHandler = new CatalogHandler(); if (CatalogHandler.GetConnectionStatus()) { MaterialItemEnumerator MaterialItemEnumerator = CatalogHandler.GetMaterialItems(); while (MaterialItemEnumerator.MoveNext()) { MaterialItem MaterialItem = MaterialItemEnumerator.Current as MaterialItem; if (MaterialItem.MaterialName == "S235JR") { Result = true; break; } } } return Result; } }