API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MaterialItemMaterialItemTypeEnum Enumeration

Defines the different material item types.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public enum MaterialItemTypeEnum
Members
  Member nameValueDescription
MATERIAL_UNKNOWN0 The unknown material item type.
MATERIAL_STEEL1 The steel material type.
MATERIAL_CONCRETE2 The concrete material type.
MATERIAL_TIMBER3 The timber material type.
MATERIAL_MISC4 The miscellaneous material type.
MATERIAL_REBAR5 The rebar material type.
MATERIAL_REBAR_MESH6 The rebar mesh material type.
See Also